2
Vote

doesn't work with vs2010

description

Since upgrading to VS2010, I'm unable to add controls to my forms.
I am able to see forms converted from vs2008 though
 
Any chance of this getting fixes? knowing that this project is somewhat frozen in the past few years
 
Thanks!

comments

Ztgreve wrote Jan 28, 2011 at 10:04 PM

I am having the same issue. I am going to browse the source code and see if I can find anything that might be inhibiting the controls from being used with VS2010.

Ztgreve wrote Jan 28, 2011 at 10:25 PM

I was able to fix the issue by copying the files from Ascend.Design to Ascend.Windows.Forms!!! The designers now work as expected.

I hope this helps anyone frustrated with the components and VS2010.

asbadwal wrote Mar 15, 2011 at 2:20 AM

I am having same issue with controls. These would not work on designer in Visual Studio 2010.
I couldn't understand your solution : which was "I was able to fix the issue by copying the files from Ascend.Design to Ascend.Windows.Forms!!! The designers now work as expected."
Does it mean renaming the Ascend.Design to Ascend.Windows.Forms or soemthing else ?

docco wrote May 2, 2011 at 1:26 PM

@Ztgreve - not sure I understand, the entire solution exists in a single folder (ex: C:\Program Files (x86)\Ascend.NET Project\Ascend.NET Windows Forms Controls\version 1.0.0.6)
What should I copy where?

10x

Callesen wrote Jun 7, 2011 at 1:24 PM

I had the same problem (Windows 7 + VS 2010)! Check if Ascend.NET is registered correct (use regedit)!
HEKY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> .NETFramework -> v2.0.50727 -> AssemblyFoldersEx -> Public Assemblies
HEKY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> .NETFramework -> v2.0.50727 -> AssemblyFoldersEx -> Public Assemblies (Common Files)
HEKY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> .NETFramework -> v2.0.50727 -> AssemblyFoldersEx -> Public Assemblies 9

if not make the same registration in all folders and restart.

wrote Feb 14, 2013 at 7:12 PM